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Adding / Removing the Centene SAcM Access Admin Customization 

May-2021 

 

Adding the Customization 

The Access Admin customization consists of modifications to a single text include-file in SAcM and a new module to 

be imported into SEM and mapped to those users requiring access to the customization. A new license to grant 

permissions to the new module (“Centene Access Admin DB”) is also required for import into SEM. 

The initial set-up requires a copy of the existing “Access” database used by the Centene Access Admin Team. The 

content of that original database is selectively copied into a new database held in SQL Server. Historical copies of 

SYSUAF listing files that were extracted from the VMS clusters are read and summaries written into the new ‘Access 

Admin DB’. A new procedure to scan the VMS clusters and update the Access Admin DB is run in background mode 

as a nightly job as a SEM Service Display. 

The include-file that requires to be changed in SAcM is: “Custom Code Display = Enterprise Accounts”. Before this file 

is changed, it needs to be copied and saved for backout purposes. 

 

Backout 

To remove the customization and revert the system to its original state, the following actions need to be done: 

 

1. Stop / remove the SEM Service display: “VMS Scan - Update Access Admin DB” [i.e., undo detailed step 13] 

2. Remove mapping to the new module for SEM users [undo detailed step 12] 

3. Replace the content of the text include-file “Custom Code Display = Enterprise Accounts” with the text that 

was copied and saved before the customization was applied [undo detailed step 3] 

4. Delete the imported SEM module “Centene Access Admin DB” [undo detailed step 2] 

5. Remove the two new ODBC System DSNs [undo detailed step 5] 

6. It is not necessary to revert the license to its initial state, (to exclude the use of the “Centene Access Admin 

DB” module), but this would be an option and thereafter all traces of the customization in SEM would have 

been removed [undo detailed step 1] 

 

Note that removing the customization will not remove the data held in the SQL Server database, but that data would 

no longer be kept up-to-date since the daily scan of the VMS clusters and the update of the database were no longer 

taking place. 
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Adding the Customization – Detailed Description 

 

1. Export the old license and Import the new license 

 

In a SEM privileged account, use the Tools > License Manager option to start the license manager window  

 

Select the current license and ‘Save’ it to a location for subsequent reloading if we were to backout the 

customization. Then use the ‘Load’ option, locate the new license provided and after loading it press OK to 

confirm the changed license. 

The file in the kit that contains the new license for importing is:  

           Centene SEM License PAK 2021-05-20-Access-Admin with extension.txt 

Copy pak file (Centene_key_pak.txt) to Options cache (Sysgem\SEM OptionsCache) and rebuild checksums using: 

“SAcM Account Manager > “Configuration” > “Options Cache” > “Rebuild Checksums”  
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2. Import the “Centene Access Admin” module 

 

  
 

In a SEM privileged account use the File > Import and Export > Import Module option. Browse for the folder 

containing the “Centene Access Admin” module provided. 

 

Import the module by following the prompts and accepting all the default options until the module has been 

imported. Do not map it to any SEM users while importing it, we will do that manually as the next step. 

The file shipped in the kit is “Centene Access Admin-2021-05-21.txt” that should be used to import the new 

module. 
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3. Save the Enterprise Accounts custom include file for backout purposes and edit it to add the customization 

Run Step 3 after Step 10 

 

In a SEM privileged account, use the Managers > Include Files option to edit the SAcM Include files. Double click 

on the “Mapped Library: SAcM Account Manager”  

 

Double click on the “Custom Code Display = Enterprise Accounts” file to edit the file, select “Edit: Text”. 

Using the text editor, first save the file for backout purposes. Then search for and replace four segments in the 

file with the four new segments included in the file “Centene Custom EA Include.txt” which is included in the kit. 

Follow the instructions in that file and then save the changes by repeatedly pressing the “OK” button. 
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4. Copy the Access Admin Team’s “Access” Database to the Authorization Server 

 

A copy of the current Access Admin Team’s “Access” database needs to be copied onto the SEM 

Authorization Server system. First, it needs to be exported from its current (.accdb) format and saved in 

Access 2002-2003 (.mdb) format. 

 

 
 

The .mdb file is needed on the SEM Authorization Server system only for introducing the customization and 

thereafter can be deleted. Place it in a location that can be easily discovered when setting a System DSN to 

point to it (see the next step). 
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5.  Add Two ODBC System DSNs  

 

Two ODBC System DSNs (using the 32-bit Data Source Administrator) need to be added on the SEM 

Authorization Server system using the same Windows domain account that runs the Windows service “SEM 

Authorization Server”. Ideally start the Data Source Administrator from SEM having logged into a Windows 

account that has the rights to access the Sysgem SQL databases. (See email from Vik Anderson dated 28-

April-2021). 

 

A. “Centene Access Admin DB” DSN 

 

Create the SQL Server DSN “Centene Access Admin DB” to point to the empty database created by Vik 

Anderson on Centene’s SQL server system. This should be similar to the DSNs already in use by SEM for 

the “Sysgem SAcM Logfile” database. 

 

 
 

B. “Centene Access DB” DSN 

 

Create the Microsoft Access Driver (*.mdb, *.accdb) DSN “Centene Access DB” to point to the copy of 

the Centene Access Admin’s “Access” DB that was copied to the SEM Authorization Server system in the 

previous step. 
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6. Copy SYSUAF Listing Files to the Authorization Server 

 

Centene have a number of SYSUAF listing files that have been created on the VMS clusters.  

 

Create a folder (on the SEM Authorization Server system) for each cluster for which the files have been 

saved and into those folders copy 12 SYSUAF files (one from each month over the last year). Also, in each of 

those folders, create a text file that has the names of the files in that folder. One filename per line, so a total 

of 12 lines in this file. This text file requires the SYSUAF file names only – not the full filespecs giving folder 

names etc. But note that the files should be listed in chronological order, oldest first. 
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7. Run the “Access to Access Admin”  conversion 

 

Log into SEM with a system privileged SEM account and map the module library “Centene Access Admin” 

that was imported in step 2. Use the option “Tools” > “Library Mappings” to select and map the new library 

to this account. Ensure that the “SAcM Account Manager” library is also mapped to this account. 

 

Double click on the option “Access-to-AccessAdmin” under the “Initial Setup of Access Admin DB” folder. 

 

Select the “Local” or “Sysgem” agent and select a location and a name for the log file that will record the 

results of this action. 

This display will read the local copy of the Access DB (via the ODBC DSN set up previously) and write the data 

into the SQL Access Admin DB (via the ODBC DSN that was set up previously). It will generate the SQL table 

and field entries in the Access Admin DB.  

Close the “Access-to-AccessAdmin” window. 
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8. Run the “Sync SYSUAF Listing with AccessAdmin DB” display 

 

Double click on the option “Sync SYSUAF Listing with AccessAdmin DB” under the 

 “Initial Setup of Access Admin DB” folder. 

 

 
 

Select the “Local” or “Sysgem” agent and select one of the files containing the list of SYSUAF listing files 

prepared in step 6. A log file will be created same folder as the list files when the display runs.  

Select the cluster name from the drop-down list provided appropriate for this set of SYSUAF listings. 

 

This task will take a few minutes to run while it scans the 12 SYSUAF listing files and updates the Access 

Admin DB with each of the accounts the files contain. 

 

Repeat the procedure for each of the set of files held for the different clusters, making VERY sure that the 

correct cluster name has been selected for each run.  

 

WARNING - An incorrect selection of the cluster name will be difficult to recover from! 

 

Close the window when all the SYSUAF files from all the clusters have been processed. 
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9. Run the “VMS Scan – Update Access Admin DB” display 

 

Double click on the option “VMS Scan – Update Access Admin DB” in the “Access Admin Maintenance” 

folder. 

 

 
 

Select all the agents for the clusters that were used in the previous step when synchronizing the SYSUAF files 

with the Access Admin database.  

 

Select an appropriate file and location name for writing a log file using the “Log File” tab in the start-up 

window. 

 

This task will take a few minutes to run. 
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10. Check the “Access Admin Database” display 

 

Start the “Access Admin Database” display  

 

 
 

Select the Local or Sysgem agent. 

 

Check the number of “Available” records required on the “Available Records” tab of the start-up window. 

The default value is 30. Does this sound appropriate? 

 

Start the display. 

 

Does it look correct? Check some of the records. How many records are in the display? How long did it take 

to load all records?  

 

Start it for a second time to see if this took an appreciably shorter time to load. 

 

Start it again, this time searching for a specific CN Ref or full name. Use filter 4 in the start-up window to 

avoid the use of a “Persistent Filter”. How long did it take to load this time? 

 

Start it again, this time using a filter on “Cluster” and type a cluster name such as “PRD” in the text field.  

How long did it take to load this time? 

 

Start it again, this time using a filter on “VMS Acc Status” with a text of “Live”. How long did it take to load 

this time? 

 

Note that none of the steps up to this point have had any effect on the live running of SAcM, and even step 3 

(which will be performed next!) does not change the saved favorites used by normal SEM users in Centene. 
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11. Check the Enterprise Accounts Customization 

 

With a privileged SEM account, that is mapped to both “Centene Access Admin DB” and “SAcM Account 

Manager” library module, start the “Enterprise Accounts” display from the  “SAcM Account Manager” 

Display Library (not from Favorites!). 

 

Start a VMS Create transaction – does the window include the additional fields at the top that have been 

provided by the customization? Do they find information from the Access Admin DB? After creating an 

account, do the details get set in the database? 

 

This completes the introduction of the customization. What follows is the use of the customization and 

allowing individual SEM users access to the customization. 
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12. Copy one of the SEM accounts used for “Mirroring”  

 

Using the “Managers” > “SEM Users” > “Accounts” menu option, select an account that is normally used for 

mirroring other users to and copy it, giving it a name appropriate for use with “Access Admin DB”. 

 

Log into this account using the menu option “Managers” > “SEM Users” > “Become User” > “Full Privileges”. 

 

In the new account, Map the modules SAcM Account Manager and Centene Access Admin. 

 

Start the Access Admin DB display and save it as a favorite. 

 

Start the Enterprise Accounts Display and save it as a favorite. 

 

Create some other test accounts in SEM and mirror them to the favorites of the account above.  Do those 

favorites work when logged into them without full privileges? 
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13. Setting up the Service Display for running the ‘VMS Scan’ in background mode 

 

The display “VMS Scan – Update Access Admin DB” is to automatically run each day in background mode as 

a SEM Service Display. 

 

With a privileged SEM account that is mapped to the Centene Access Admin DB library, start the menu 

option: “Tools” > “Service Displays and Scheduled Reports”, select the “VMS Scan – Update Access Admin 

DB” display and click “Add Configuration”. Use the default name for the new configuration. 

 

Click “Parameters” and select the same set of agents as was used in step 9.  Select the first three options 

under the heading “Show Results” (leaving out the matched records).  Set up a log file on the Log File tab. 

 

Click “Schedule” and “Scheduled intervals at:” > “Set” and select an appropriate time of day to run every day 

(e.g., at 02:00) 

 

Click “enable this configuration”. 

 

On the “Service” tab, use the options: Stop > Deinstall > Install > Start. 

 

 


